वर्डप्रेस गुटेनबर्ग संपादक को अक्षम करने और क्लासिक संपादक का उपयोग कैसे करें

यदि आपने पहले ही नहीं सुना है, तो जिस तरह से आप वर्डप्रेस के साथ सामग्री बनाते हैं, वह जल्द ही पूरी तरह से गुटेनबर्ग संपादक की शुरूआत के साथ बदलने वाला है।

वर्डप्रेस 5.0 में शुरू, जो जल्द से जल्द जारी किया जा सकता है 19 नवंबरजब आप पोस्ट, पेज, या किसी अन्य प्रकार की वर्डप्रेस सामग्री बनाते हैं जो डिफ़ॉल्ट संपादक का उपयोग करता है, तो गुटेनबर्ग संपादक वर्तमान टिनीएमसीई संपादक की जगह लेगा।

पढ़ें: वर्डप्रेस गुटेनबर्ग संपादक का उपयोग कैसे करें & # 8211; शुरुआती के लिए एक पूर्ण गाइड

हालांकि, हर कोई नए गुटेनबर्ग संपादक (कम से कम अभी नहीं) का उपयोग करना चाहता है। अगर आप गुटेनबर्ग संपादक को निष्क्रिय करना और क्लासिक टिनीएमसीई संपादक का उपयोग करना संभव है, तो आप सोच रहे होंगे।

उस प्रश्न का उत्तर है, हाँ

और इस पोस्ट में, मैं उन कुछ कारणों पर चर्चा करूँगा, जिन पर आप गुटेनबर्ग के संपादक को निष्क्रिय करने पर विचार कर सकते हैं।

फिर, मैं आपको बिल्कुल दिखाता हूं कि आप कैसे वर्डप्रेस 5.0 में गुटेनबर्ग संपादक को अक्षम कर सकते हैं और वर्तमान टिनीएमसीई संपादक का उपयोग कर सकते हैं जिससे आप पहले से परिचित हैं।

सिफारिश की:

क्यों तुम Gutenberg संपादक अक्षम करना चाहते हो सकता है

यदि आप गुटेनबर्ग संपादक से पहले से परिचित नहीं हैं, तो मेरा सुझाव है कि आप गुटेनबर्ग संपादक क्या हैं और गुटेनबर्ग संपादक का उपयोग कैसे करें, इस पर मेरी पोस्ट देखें।

संक्षेप में, गुटेनबर्ग संपादक लाता है ब्लॉक-आधारित संपादन वर्डप्रेस के समान, मध्यम संपादक कैसे काम करता है या एक हल्का पेज बिल्डर। यह सामग्री निर्माण के संदर्भ में बहुत सारे लाभ प्रदान करता है क्योंकि आप कर सकते हैं:

  • किसी भी कोड का उपयोग करने की आवश्यकता के बिना एक उत्पाद तुलना तालिका, प्रशंसापत्र, या यहां तक ​​कि एक साधारण बटन … जैसे अधिक स्टाइल सामग्री बनाने के लिए “ब्लॉक” को शामिल करें।
  • अधिक जटिल लेआउट बनाने के लिए कॉलम का उपयोग करें। फिर से, किसी भी कस्टम कोड की आवश्यकता के बिना।

यदि आप अपने लिए गुटेनबर्ग आज़माना चाहते हैं, इस पेज पर जाएं

तो इस तरह के लाभों के साथ, कोई भी गुटेनबर्ग संपादक को अक्षम क्यों करना चाहेगा? खैर, मुझे लगता है कि कुछ अलग कारण हैं।

गुटेनबर्ग संपादक को अक्षम करने के लिए 3 कारण

सबसे पहले, वहाँ है सुपरिचय। यदि आप वर्षों से वर्डप्रेस का उपयोग कर रहे हैं और पहले से ही वर्तमान संपादक से खुश हैं, तो हो सकता है कि आप नए संपादक को सीखने के लिए समय बिताना न चाहें।

दूसरा, वहाँ है अनुकूलता। जबकि गुटेनबर्ग टीम इसे यथासंभव संगत बनाने का प्रयास कर रही है, आप कम से कम शुरुआत में अपनी साइटों पर कोई जोखिम नहीं लेना चाहते हैं। यहां तक ​​कि अगर आप इसे केवल कुछ महीनों के लिए अक्षम करते हैं, तो यह डेवलपर्स को किसी भी बढ़ते दर्द को बाहर निकालने का मौका देगा।

अंत में, वहाँ स्थिति है जहाँ आप हैं ग्राहकों के लिए वेबसाइटों का निर्माण। यदि आप एक फ्रीलांसर या एजेंसी हैं, जो क्लाइंट साइटों का प्रबंधन करती है, तो यदि आपके इंटरफ़ेस में अचानक बदलाव होता है, तो आपके ग्राहक आपसे बहुत परेशान हो सकते हैं।

निश्चित रूप से, यह वास्तव में आपकी गलती नहीं है – लेकिन वे यह नहीं जानते हैं। और उन्हें, ऐसा लगता है जैसे आप मनमाने ढंग से इंटरफ़ेस बदल रहे हैं जो वे पहले से ही सीख चुके हैं … और वे इस बारे में खुश नहीं हो सकते हैं। इसलिए चीजों को सुचारू रूप से चलाने के लिए और अपने ग्राहकों की वर्कफ़्लोज़ को बाधित करने से बचने के लिए, आप बस गुटेनबर्ग के संपादक को निष्क्रिय करना चाहते हैं और अपने अनुभव को वही रख सकते हैं।

कैसे Gutenberg संपादक को अक्षम करने के लिए और TinyMCE संपादक का उपयोग कर रखें

वर्डप्रेस कोर टीम समझती है कि हर कोई गुटेनबर्ग संपादक का उपयोग नहीं करना चाहेगा, इसलिए उन्होंने वास्तव में गुटेनबर्ग संपादक के बजाय टिनीएमसीई संपादक का उपयोग करने में आपकी मदद करने के लिए एक आधिकारिक समाधान बनाया है।

यह समाधान आधिकारिक है क्लासिक संपादक लगाना।

भले ही वर्डप्रेस 5.0 अभी तक जारी नहीं किया गया है, आप इस प्लगइन को कॉन्फ़िगर कर सकते हैं आज और यह वर्डप्रेस 5.0 जहाजों के साथ काम करना शुरू कर देगा।

यह प्लगइन दो काम कर सकता है।

सबसे पहले, आप यह कर सकते हैं पूरी तरह से गुटेनबर्ग संपादक को अक्षम करें। इस मोड में, यह अनिवार्य रूप से आपके इंटरफ़ेस से गुटेनबर्ग संपादक के सभी निशान मिटा देगा और चीजों को ठीक उसी तरह रखेगा जैसे वे वर्डप्रेस 5.0 से पहले थे।

दूसरा, इसमें एक अन्य मोड भी शामिल है जो आपको देता है टिनीएमसीई संपादक और गुटेनबर्ग संपादक दोनों का उपयोग करें। इस मोड में, गुटेनबर्ग संपादक सक्रिय हो जाएगा डिफ़ॉल्ट रूप से। लेकिन इंटरफ़ेस में एक लिंक भी शामिल होगा जो आपको पोस्ट-बाय-पोस्ट आधार पर TinyMCE संपादक पर वापस जाने की अनुमति देता है।

यहां देखिए यह कैसे काम करता है।

चरण 1: स्थापित करें और क्लासिक संपादक प्लगइन को सक्रिय करें

आरंभ करने के लिए, क्लासिक संपादक प्लगइन को स्थापित और सक्रिय करें जैसे कि आप WordPress.org से कोई अन्य प्लगइन करेंगे:

क्लासिक संपादक प्लगइन स्थापित करें

चरण 2: क्लासिक संपादक मोड चुनें

क्लासिक संपादक प्लगइन को स्थापित और सक्रिय करने के बाद, आपको यह कॉन्फ़िगर करने की आवश्यकता है:

  • केवल TinyMCE संपादक का उपयोग करें
  • उपयोग दोनों TinyMCE संपादक और गुटेनबर्ग संपादक

ऐसा करने के लिए, पर जाएं सेटिंग्स → लेखन अपने वर्डप्रेस डैशबोर्ड में। फिर, के लिए देखो क्लासिक संपादक सेटिंग्स विकल्प:

गुटेनबर्ग संपादक को अक्षम कैसे करें

यदि आप चुनते हैं ब्लॉक एडिटर को क्लासिक एडिटर से बदलें ‘, तो आप कर रहे हैं! जब वर्डप्रेस 5.0 जहाज – आप बस उसी परिचित TinyMCE संपादक का उपयोग करते रहेंगे, तो आपके संपादक के अनुभव के बारे में कुछ भी नहीं बदलेगा।

दूसरी ओर, यदि आप चुनते हैं डिफ़ॉल्ट रूप से ब्लॉक संपादक का उपयोग करें और वैकल्पिक लिंक को क्लासिक संपादक में वापस शामिल करें, आप पोस्ट-बाय-पोस्ट के आधार पर TinyMCE संपादक का उपयोग करना सीखना चाहते हैं।

चरण 3: TinyMCE संपादक का उपयोग कैसे करें (यदि दोनों का उपयोग कर)

याद रखें – यह चरण केवल तभी लागू होता है जब आप दोनों संपादकों का उपयोग करने का विकल्प चुनते हैं।

जब आप एक नया पोस्ट या पेज बनाते हैं, तो आपको दो विकल्प मिलेंगे:

  • नियमित नया जोड़ें बटन गुटेनबर्ग संपादक का उपयोग करता है
  • नया नया जोड़ें (क्लासिक) बटन TinyMCE संपादक का उपयोग करता है

क्लासिक संपादक तक पहुँचें

और अगर आप एक के साथ काम करना चाहते हैं मौजूदा पोस्ट या पृष्ठ, आपके पास TinyMCE संपादक तक पहुंचने के लिए कुछ विकल्प होंगे।

सबसे पहले, आपको एक नया मिलेगा क्लासिक संपादक विकल्प जब आप किसी मौजूदा पोस्ट या पेज पर होवर करते हैं:

क्लासिक संपादक में पुरानी पोस्ट संपादित करें

दूसरा, आप Gutenberg संपादक से TinyMCE संपादक को वर्डप्रेस टूलबार के माध्यम से वास्तविक संपादन पोस्ट इंटरफ़ेस से स्विच करने में सक्षम होंगे:

क्लासिक संपादक टूलबार विकल्प

और यह सब वहाँ है!

अंतिम विचार – क्या यह गुटेनबर्ग संपादक को अक्षम करने के लिए एक अच्छा विचार है?

में लघु अवधि, गुटेनबर्ग संपादक को अक्षम करने में कोई समस्या नहीं है, इसलिए यदि आप TinyMCE संपादक का उपयोग बंद करने के लिए तैयार नहीं हैं, तो इसे करने के लिए स्वतंत्र महसूस करें। वास्तव में, इसे अक्षम करने से आप किसी भी अल्पकालिक बढ़ते दर्द से बच जाएंगे और वर्डप्रेस समुदाय को किसी भी कीड़े को काम में लाने का समय दे सकते हैं, इससे पहले कि आप इसका उपयोग करें।

हालाँकि, यदि आप गुटेनबर्ग को अक्षम करने पर विचार कर रहे हैं लंबे समय में, मुझे लगता है कि याद रखने के लिए एक महत्वपूर्ण बात है।

क्योंकि गुटेनबर्ग संपादक डिफ़ॉल्ट संपादक होगा, जो लोग प्लगइन्स और थीम का निर्माण करते हैं वे अपने नए उत्पादों और सुविधाओं को विकसित करना शुरू कर देंगे केवल मन में गुटेनबर्ग के साथ।

अल्पावधि में, मुझे यकीन है कि अधिकांश डेवलपर्स दोनों संपादकों का समर्थन करना जारी रखेंगे। लेकिन अब से साल, आप कार्यक्षमता पर याद करने के लिए शुरू कर सकते हैं यदि आप का उपयोग करते रहते हैं गुटेनबर्ग संपादक के बजाय टिनीएमसीई संपादक। यह निश्चित रूप से आपको आगे बढ़ने का ध्यान रखना चाहिए।

क्या आपके पास गुटेनबर्ग संपादक को अक्षम करने और क्लासिक टिनीएमसीई संपादक का उपयोग करने के बारे में कोई अन्य प्रश्न हैं? एक टिप्पणी छोड़ दो और मैं मदद करने की कोशिश करूँगा!

Leave a Comment

Your email address will not be published. Required fields are marked *

Scroll to Top